Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Intraweb using HTTPS
I've recently purchased the ultimate version of intraweb 15 to be able to use the HTTPS feature, but have not been able to successfully get it to work. I have tried doing what the StandAloneSSL Demo has done but still no luck. The error message that I get is "EidOSSLLoadingCertError with message 'Could not load certificate. error: 00000000:lib(0):func(0):reason(0)'." 

- I have my 3 PEM files(cert.pem, root.pem, key.pem) and my 2 SLL .dll files(libeay32.dll, ssleay32.dll) in the same directory as my .exe file.
- I have set the SSL PORT in ServerController properties to 443
- I have set ConnectionMode to cmSecure in Main.dfm file(The only page for my site).

And still nothing. Could Someone please help me with step-by-step instructions on how to correctly implement the usage of https instead of http.

Thank you! All the help I can get is really appreciated.

Forum Jump:

Users browsing this thread: 1 Guest(s)