Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
TIWFileUploader behind reverse proxy
#1
I have difficulties getting TIWFileUploader to work on production server. FileUploader works well in development environment so I suspect it could be related to the reverse proxy / url rewrite on the production server.

Apache config:
  ProxyPass "/stocklive2" "http://127.0.0.1:6824"
  ProxyPassReverse "/stocklive2" "http://127.0.0.1:6824"

The property ServerController RewriteUrl (URLBase) has been set accordingly to '/stocklive2', and the rest of the app works well. Component is named "MyFileUploader'.

An error is logged in app_session.log: 127.0.0.1   /$/callback   ,  callback=MYFILEUPLOADER.DoOnAsyncUploadError2

In the client browser, the file upload progress bar is shown ok until completed, when browser console shows this JS error briefly before session is recreated:

IWFileUploader__3778771729.js:1 POST https://tcs.myairline.net/stocklive2/&#3...TrackID_=1 404 (Not Found)

Any suggestions on what to do to get TIWFileUploader to work with reverse proxy or how to make it log what's going wrong?
Reply
#2
I'll need to recreate something trying to simulate this environment. Please allow me 1-2 days and I'll get back to you on this.

Cheers
Reply
#3
(05-04-2021, 02:19 AM)Alexandre Machado Wrote: I'll need to recreate something trying to simulate this environment. Please allow me 1-2 days and I'll get back to you on this.

Cheers

Great! Thanks!
Reply
#4
Hi there,

sorry for the late response... took me a little longer than anticipated.

I tested this scenario using 3 different servers (IIS+URLRewrite, Apache, and Abyss) all 3 worked correctly as expected.

You didn't mention what reverse proxy server you are using, though.

Another point is that the OnAsyncUploadError event only occurs when there is an upload error. Do you have a genuine upload error prior to the JavaScript error?
Reply
#5
Hi, and thank you for looking into this.

I am using apache 2.4 as reverse proxy and have created a debug app with only the file upload page to debug the issue. The app is behind a WAF web access front/firewall on which I have no control, so there could be issues there. But the rest of the app works well in this configuration.

Included screendumps are the AsyncUploadError eventparams and the 404 error shown in the browser console. The 404 is what grabs my attention as it is (if I understand correctly) a request to a iw-app js resource.

Could the screendumps give a clue to what is going wrong?


Attached Files Thumbnail(s)
       
Reply
#6
Can you show me the other requests (the ones that work and return status code 200)?

If it contains sensitive data, please feel free to send it to me via email (alexandre at atozed dot com)
Reply
#7
Case is solved. The file upload issue was with the company web access front firewall, not with the reverse proxy, apache or intraweb. TCS (Tata consulting) made some config changes, and then all worked as expected.

Sorry for taking your time when the cause of error was elsewhere.

Sincerely,
Øystein Jakobsen
SAS Airline
Reply


Forum Jump:


Users browsing this thread: 3 Guest(s)