Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Debug Failure Between Cosmos and VMWare
Yesterday I started having issues with testing my Cosmos code. Whenever I click the "Cosmos" button at the top of Visual Studio, It goes through the normal build and debug procedure, but when VMWare starts, I don't see my OS(named 'Experiment One'). I see:
ISOLINUX 6.03 2014-10-06 ETCD Copyright (C) 1994-2014 H. Peter Anvin et al
Loading Experiment... failed!
No files found!
boot: _
The first line is normal, but lines two and three seem to tell that the failure was due to an absence of some file. The underscore is a cursor. If I type "Experiment One" after the boot: statement, it gives me the failure message and the boot statement again.

Maybe related: If I open VMWare standalone, I can see a library of virtual machines. I right-clicked the one labeled "Cosmos" and clicked "Delete from disk" before all this chaos happened. Is there a way to fix this?

EDIT: I tried again with another project, received an error: 'Unable to use the previously selected debugger. Please select another one. I am going to try and reinstall VMWare.
Well, I ran an installer-based repair on both VS2019 and VMWare. I then reinstalled Cosmos Userkit. Same issue.
Are there any build errors?

"Unable to use the previously selected debugger"
Where was that message from?
Pop up from Visual Studio. Happened after I repaired VS2019 and VMWare. Reinstalling Cosmos eliminated this. I think when I repaired VS2019 it deleted part of Cosmos. I still get he No files found in VMWare, though.

No build errors.
Going to try posting an .mp4 screen recording of my debugging attempts.

EDIT: yep, nope. The page times out every time I try to post the comment. If I could get an alternative form of contact @kudzu then I could try sending it to you that way.
So all is fixed now?
No, still seeing “No file found!”. I can post a screenshot in a while or maybe try to email my recording.
I am about ready to lose it. Upon loading the project this time, I see an error.
"One or more projects in this solution was not loaded correctly. See output window for details."

I looked, and sure enough, I see:
An error was encountered while opening associated documents the last time this solution was loaded. Document load is being skipped during this solution load in order to avoid that error.

Where I normally see my code, I now see a blank grey canvas.

Would maybe removing my Userkit  and installing the Devkit help?
Can you reload the project, because it can't work without loading the files.
The Userkit should work, so I dont think there is a need to switch to the devkit.
In my experience rebuilding the project fixed any problems with no file found in VMWare. Do you maybe get any errors in the ouput tab when running normally?
No output errors, and I’ve rebuilt some twenty times with two different Cosmos projects. This is the first time that it has failed to load in VS2019

Forum Jump:

Users browsing this thread: 1 Guest(s)